docwhat's avatardocwhat's blog

It's All Text! 1.4 (FF3.6 compatible)

I have just finished Firefox 3.6 after working like crazy since FF 3.6 came out.

It only works in FF3.6, but the statistics show that the users of It’s All Text! upgrade their browser almost immediately after a new version comes out, so I’m not worried.

It’s approved and available via the normal spot.

I apologize for not getting this done before FF 3.6. I don’t have a real excuse except being lazy and busy with other things. But I have to say the amount of emails I got asking for a FF 3.6 version definitely got me off my butt. ;-)

Ciao!

Comments

Gravatar for dork
Dork

It’s a pity that it doesn’t work in 3.5.7 anymore. Upgrading Fx now is not an option since 50% of my other extensions aren’t compatible.

Gravatar for docwhat
docwhat

Oh, but it does work in 3.5. I was lazy and didn’t test it initially. I fixed the versions last night.

If you go to the IAT page on AMO you can get it for 3.5.

Ciao!

Gravatar for ben poliakoff
Ben Poliakoff

“It only works in FF3.6, but the statistics show that the users of It’s All Text! upgrade their browser almost immediately after a new version comes out, so I’m not worried.”

How much trouble might it be to make it compatible with the current “devel” branch of Firefox (3.7)? I love IAT and would be very happy to be using it with 3.7!

Gravatar for martin miller
Martin Miller

v1.4 will NOT install on Firefox 3.5.7 — I just tried it again following the “IAT page on AMO” you provided. I get the same result when the FF Extension Manager tries to update it — namely the following error message is displayed “It’s All Text! 1.4 could not be installed because it is not compatible with Firefox 3.5.7.”.

Something with the version checking isn’t right.

Gravatar for docwhat
docwhat

I wonder if the .xpi is being cached by FF? Can you try restarting FF and seeing if that helps? If not, email me directly or IM me we can see if we can figure it out.

Worse-case — I’ll create a new version with hardcoded bumped version numbers.

Gravatar for docwhat
docwhat

Dunno. I haven’t even looked at 3.7 yet; 3.6 just came out! :-) I’ll take a quick look tonight. Worse case, you can dump the unzipped .xpi in your extensions directory and manually change the version numbers and see what happens. :-)

File any bugs you find at http://trac.gerf.org/itsalltext

Gravatar for martin miller
Martin Miller

I don’t think the .xpi is being cached by FF is the issue. I tried it again after restarting FF and then again after a full computer reboot but got exactly the same error message about it not being compatible with Firefox 3.5.7 each time.

On the description for v1.4, you wrote “It only works in FF3.6”, is there perhaps someplace you’ve hardcoded it so it won’t work in any lessor version of FF?

Gravatar for chris lasher
Chris Lasher

As mentioned by PhiLho on the plugin comments, in the install.rdf file, you have set em:minVersion=“3.6” instead of =“3.5”. If this plugin does actually work with 3.5, please set the minVersion to 3.5.

I tried to file this as a bug report, but your Trac does not seem to support OpenID fully. I’m unable to log in using MyOpenID.com, and so I cannot file bug reports. You might want to check its configuration.

Gravatar for martin miller
Martin Miller

Yes, @Chris Lasher is correct, that the minVersion setting is what is preventing it form installing on FF 3.5.7. I manually changed the value and installed the update.

A quick test at an unrelated web site seems to verify that it will indeed work with v3.5.7… after the change.

Gravatar for colin dean
Colin Dean

@Chris:

OpenID login from myopenid.com works fine for me on trac.gerf.org.

@Christian:

+1 on the 3.5.7 incompatibility.

Gravatar for docwhat
docwhat

I created a new version, 1.4.1, but AMO is having troubles of some sort. You can get it by clicking on the View All Versions link at the bottom of the It’s All Text! page.

Gravatar for austin
Austin

Wouldn’t it be nice if when installing addons that are outside of the users version users had an option to “install anyways” at their own risk? But perhaps all we’d have is a bunch of people with screwed up browsers saying “Mozilla sucks, Internet Explorer rocks!” …

Gravatar for aziz light
Aziz Light

I love It’s All Text. I loved it since it’s first release. However, I always had issue with it on OS X. I finally found a way! Well at least if you use Textmate. You first need to install the Terminal app (mate):

  • Click on Help -> Terminal Usage…
  • Choose where you want to install mate
  • Click on “Create Link”

If you already installed the mate command but don’t know where it is, open Terminal.app and type “which mate”. Finally, in It’s All Text’s preferences, copy the path to the mate command. In my case, it was /usr/bin/mate

Now it should be working fine.

Submit a Comment

docwhat

The personal blog of Christian Höltje.
docwhat docwhat contact